🩹 fix not working template

Update API dependency so that TS build does not bail out on a missing type.

 * clone project
 * npm i
 * npm run build

💥 This fails with typing errors on `WorkadventureAPI`

Bump to latest API version (^1.4.0)
pull/21/head
Cedric Gatay 1 year ago
parent 13bb48c496
commit 40fe489e3b
No known key found for this signature in database
GPG Key ID: 34DC3048FDED6CDD
  1. 14
      package-lock.json
  2. 2
      package.json

14
package-lock.json generated

@ -8,7 +8,7 @@
"version": "1.0.0",
"license": "MIT",
"devDependencies": {
"@workadventure/iframe-api-typings": "^1.2.1",
"@workadventure/iframe-api-typings": "^1.4.0",
"eslint": "^7.24.0",
"html-webpack-plugin": "^5.3.1",
"ts-loader": "^8.1.0",
@ -329,9 +329,9 @@
"dev": true
},
"node_modules/@workadventure/iframe-api-typings": {
"version": "1.2.1",
"resolved": "https://registry.npmjs.org/@workadventure/iframe-api-typings/-/iframe-api-typings-1.2.1.tgz",
"integrity": "sha512-BZd+x5+iWHHfImwB1POEb/vH4+hpUX+YubwCUU0oLIhBLSquzNjH6PQich1VWvP62FO1d+ZEiVhV1iV8SXF6PA==",
"version": "1.4.12",
"resolved": "https://registry.npmjs.org/@workadventure/iframe-api-typings/-/iframe-api-typings-1.4.12.tgz",
"integrity": "sha512-GN2oFlgwK8PAv6Hz1EwmixmP12AUUz8Y0bQvXHsnbfpX2oOa/PUiYtFaNc1f1D4Emv88oRyw6NR+RouJM7XxXQ==",
"dev": true
},
"node_modules/@xtuc/ieee754": {
@ -7757,9 +7757,9 @@
"dev": true
},
"@workadventure/iframe-api-typings": {
"version": "1.2.1",
"resolved": "https://registry.npmjs.org/@workadventure/iframe-api-typings/-/iframe-api-typings-1.2.1.tgz",
"integrity": "sha512-BZd+x5+iWHHfImwB1POEb/vH4+hpUX+YubwCUU0oLIhBLSquzNjH6PQich1VWvP62FO1d+ZEiVhV1iV8SXF6PA==",
"version": "1.4.12",
"resolved": "https://registry.npmjs.org/@workadventure/iframe-api-typings/-/iframe-api-typings-1.4.12.tgz",
"integrity": "sha512-GN2oFlgwK8PAv6Hz1EwmixmP12AUUz8Y0bQvXHsnbfpX2oOa/PUiYtFaNc1f1D4Emv88oRyw6NR+RouJM7XxXQ==",
"dev": true
},
"@xtuc/ieee754": {

@ -4,7 +4,7 @@
"main": "index.js",
"license": "MIT",
"devDependencies": {
"@workadventure/iframe-api-typings": "^1.2.1",
"@workadventure/iframe-api-typings": "^1.4.0",
"eslint": "^7.24.0",
"html-webpack-plugin": "^5.3.1",
"ts-loader": "^8.1.0",

Loading…
Cancel
Save